TEL:
华为交换机NQA与静态路由联动
| 发布时间: 2019-06-10 21:07:33 | 873 次浏览

一、NQA的原理及应用

 定义:

  网络质量分析NQA,是一种实时的网络性能探测和分析技术,能够对网络抖动、丢包率、网络时延等信息进行分析和统计,实时监控网络的QoS,同时也能让管理者快速定位故障点。

利用NQA的测试结果,用户可以:

 

1.及时了解网络的性能状况,针对不同的网络性能,进行相应的处理;

 

2.对网络故障进行诊断和定位。

 

NQA还提供了与Track和应用模块联动的功能,实时监控网络状态的变化,及时进行相应的处理,从而避免通信的中断或服务质量的降低。 

 

NQA具有以下几个特点:

1.支持多种测试类型

   传统的Ping功能是使用ICMP(Internet Control Message Protocol,互联网控制报文协议)测试数据包在本端和指定目的端之间的往返时间。NQA是对Ping功能的扩展和增强,它提供了更多的功能。

   目前NQA支持11种测试类型:ICMP-echo、DHCP、DNS、FTP、HTTP、UDPjitter、SNMP、TCP、UDP-echo、Voice和DLSw测试。

 2.支持多测试组并发

   NQA模块支持多个测试组并发,用户可以根据需求手工配置并发个数。但对于DHCP测试,同一时刻只允许有一个测试组进行测试。

 3. 支持联动功能

   联动功能是指NQA提供探测功能,把探测结果通知其他模块,其他模块再根据探测结果进行相应处理的功能。目前实现了与VRRP、静态路由、备份中心和策略路由的联动。

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

NQA联动主要应用在网络要求不高的场景使用,像企业到运营商的一般都是走静态路由,像这种网络一般都是秒级以上的;数据中心这种要求高的场景用BFD这种毫秒级的联动方法是比较合适的。

 timeout、probe-count、frequency和interval命令之间有制约关系,所以配置改四条命令时需要注意命令取值及相互配合,否则会导致测试失败。

  • 对于质量较差、传输速率不高的网络,为了保证nqa探测报文能够收到回应,需要加大发送探测报文的超时时间timeout取值。
  • 对于不可靠网络,可将探测次数probe-count取值设置相对大些。因为可能发送较大次数的探测报文才能获得探测成功。
  • 发送报文的时间间隔interval取值必须大于timeout取值。
  • 自动执行测试的时间间隔frequency取值必须大于等于interval和probe-count取值的乘积。

例子:

nqa test-instance admin CNC

  test-type icmp                                   //配置nqa测试类型
  destination-address ipv4 61.1.1.2     //配置nqa测试目的地址(路由可达即可)
  frequency 6                                        //配置nqa测试试例的测试周期
  interval seconds 3                              //配置nqa测试报文的发送间隔
  timeout 2
  probe-count 2                                    //配置一次测试的探针数
  start now

 二、实验拓扑

三、组网要求

1. 双线nat接入

2.实现访问联通走联通出口,访问电信走电信出口

3.通过NQA 对链路进行监测,实现任意出口故障,不影响用户上网(如果联通故障,原本走联通的流量走电信,反之亦然)

 四、配置

①运营商基础配置

AR2:

interface GigabitEthernet0/0/0
ip address 61.1.1.2 255.255.255.248 
#
interface GigabitEthernet0/0/1
ip address 198.1.1.1 255.255.255.252 
#

interface LoopBack0
ip address 100.1.1.1 255.255.255.255 
#
ospf 1 
area 0.0.0.0 
network 61.1.1.0 0.0.0.7 
network 100.1.1.1 0.0.0.0 
network 198.1.1.0 0.0.0.3

----------------------------------------------------------

AR3:

interface GigabitEthernet0/0/0
ip address 198.1.1.2 255.255.255.252 
#
interface GigabitEthernet0/0/1
ip address 202.1.1.2 255.255.255.0 
#
interface LoopBack0
ip address 200.2.2.1 255.255.255.255 
#
ospf 1 
area 0.0.0.0 
network 198.1.1.0 0.0.0.3 
network 200.2.2.1 0.0.0.0 
network 202.1.1.0 0.0.0.7

测试:

②用户配置:

AR1:

1)基础配置

interface GigabitEthernet0/0/0
ip address 61.1.1.1 255.255.255.248 
#
interface GigabitEthernet0/0/1
ip address 202.1.1.1 255.255.255.248 
#
interface GigabitEthernet0/0/2
ip address 10.1.1.1 255.255.255.0

 2)NAT配置

#创建内网源地址acl

acl number 2000 

rule 5 permit source 10.1.1.0 0.0.0.255

 

#调用acl进行nat

interface GigabitEthernet0/0/0
ip address 61.1.1.1 255.255.255.248 
nat outbound 2000

interface GigabitEthernet0/0/1
ip address 202.1.1.1 255.255.255.248 
nat outbound 2000

3)配置NQA

#联通nqa实例

nqa test-instance admin CNC 
test-type icmp
destination-address ipv4 61.1.1.2
frequency 6
interval seconds 3
timeout 2
probe-count 2
start now

#电信nqa实例

nqa test-instance admin CTC 
test-type icmp
destination-address ipv4 202.1.1.2
frequency 6
timeout 2
probe-count 2
start now

通过“dis nqa results test-instance admin CNC” 查看Completion:success  ,说明探测成功了

#配置静态路由联动

 

ip route-static 100.1.1.0 255.255.255.0 61.1.1.2 track nqa admin CNC   //联通的流量走联通,并进行NQA联动
ip route-static 200.1.1.0 255.255.255.0 202.1.1.2 track nqa admin CTC //电信的流量走联通,并进行NQA联动

ip route-static 0.0.0.0 0.0.0.0 202.1.1.2 track nqa admin CTC    //走电信
ip route-static 0.0.0.0 0.0.0.0 61.1.1.2 preference 61 track nqa admin CNC  //走联通
上面两台默认路由,如果走电信的断了,走电信的默认路由会消失;如果走联通的断了也是一样,这样两条链路单独断那条都不会断网;两条默认路由为了不出现负载分担的情况,降低其中一条的优先级。

 

五、测试

断开AR3和交换机LSW2的连线,丢几个包后恢复正常,说明流量已经切换到了联通去了;链路恢复后不会出现丢包现象

 

断电信之后的路由表:

 

 

断联通之后的路由表: